Degraded performance on RTC Wiki & Forum

Incident Report for RetroTechCollection

Resolved

This incident has been resolved.
Posted Jul 07, 2026 - 16:18 UTC

Monitoring

We have implemented a fix and we are observing error rates and performance return to baseline. We will continue to monitor the situation.
Posted Jul 07, 2026 - 16:03 UTC

Identified

We have identified a configuration issue on our server cluster that is causing slow performance. We are currently implementing a fix.
Posted Jul 07, 2026 - 15:55 UTC

Investigating

Our team is currently investigating a potential Denial of Service attack against the RetroTechCollection Forum & Wiki. All other services are unaffected, we have implemented mitigations as part of our standard operating procedures. During this time, you may experience Cloudflare Challange screens or Imunify360 challange screens when viewing our websites. Our API services are degraded due to our DDoS mitigation procedures. We apologise for the inconvinience and will update this status as the situation progresses.
Posted Jul 07, 2026 - 14:49 UTC
This incident affected: RetroTechCollection Wiki (Website Frontend, API) and RetroTechCollection Forum (Website Frontend).