Degraded RTC Wiki & Forum Performance

Incident Report for RetroTechCollection

Postmortem

At 18:00 UTC we detected increased latency across the RetroTechCollection network, specifically RTC Wiki and RTC Forum. RTC Collector was uneffected. This performance degredation was due to instability within our internal networking infrastructure, we migrated RTC Wiki and RTC Forum to a different region within our infrastructure which mitigated the issue.

Posted Mar 30, 2026 - 21:03 UTC

Resolved

This incident has been resolved.
Posted Mar 30, 2026 - 21:00 UTC

Monitoring

A fix has been implemented and we have observed latency across the RTC network return to normal. We will continue to monitor the fix.
Posted Mar 30, 2026 - 20:59 UTC

Update

We are continuing to work on a fix for this issue. We hope to have the issue resolved shortly. You may experience a brief period of service unavaliability whilst we implement a fix.
Posted Mar 30, 2026 - 19:01 UTC

Identified

The issue has been identified and we are currently working on implementing a fix.
Posted Mar 30, 2026 - 18:12 UTC

Investigating

We are currently investigating degraded performance issues across the RTC Wiki and Forum. We will update this incident as more information becomes avaliable.
Posted Mar 30, 2026 - 18:04 UTC
This incident affected: RetroTechCollection Wiki (Website Frontend, Website Backend (MediaWiki), API), RetroTechCollection CDN, and RetroTechCollection Forum (Website Frontend, Website Backend (XenForo)).