RTC Wiki and Forum Degraded Performance

Incident Report for RetroTechCollection

Resolved

Essential maintenance on RTC Forum has now been completed. Both RTC Wiki and Forum are now restored to full operation.
Posted Mar 03, 2026 - 18:02 UTC

Update

We are now conducting critical maintenance on RTC Forum
Posted Mar 03, 2026 - 17:58 UTC

Monitoring

We are currently monitoring the fix implemented for both the RTC Wiki and Forum. Whilst we monitor, you may experience degraded performance across RTC.
Posted Mar 03, 2026 - 17:50 UTC
This incident affected: RetroTechCollection Wiki (Website Frontend, Website Backend (MediaWiki), API) and RetroTechCollection Forum (Website Frontend, Website Backend (XenForo)).