Estate wide service disruption

Incident Report for RetroTechCollection

Postmortem

Our hosting provider encounted a system error in which denied access to our database server which holds all information for the Wiki and Forum. This denial of access was due to an administrative error.

Posted Apr 30, 2025 - 14:15 UTC

Resolved

This incident has been resolved.
Posted Apr 29, 2025 - 19:43 UTC

Update

We are still working on the issue. We will update this page as soon as possible
Posted Apr 29, 2025 - 17:58 UTC

Update

We are currently working with our hosting provider to solve the issue, we expect as resolution by 18:30 GMT
Posted Apr 29, 2025 - 16:41 UTC

Identified

An issue with the database authorization has been identified, we are currently working to fix the issue as soon as possible. This issue is currently affecting all of our web-based infrastructure, including the Wiki, Forum and Landing Page.

Users are currently unable to access any web-facing services.
Posted Apr 29, 2025 - 16:25 UTC

Update

We are continuing to investigate this issue.
Posted Apr 29, 2025 - 16:19 UTC

Update

We are investigating the issue which is now affecting all of our web-based services
Posted Apr 29, 2025 - 16:17 UTC

Update

We are continuing to investigate this issue with our hosting partners. We will update this incident as soon as possible.
Posted Apr 29, 2025 - 16:15 UTC

Investigating

We are currently investigating an issue with database connection affecting our database server and our web servers.
Posted Apr 29, 2025 - 16:08 UTC
This incident affected: RetroTechCollection Wiki (Website Frontend, Website Backend (MediaWiki), API), RetroTechCollection CDN, RetroTechCollection Server Cluster, RetroTechCollection Database, and RetroTechCollection Forum (Website Frontend, Website Backend (XenForo)).