Our CDN provider, Cloudflare suffered a major outage (https://www.cloudflarestatus.com/incidents/8gmgl950y3h7) effecting RTC Collector and RetroTechCollection, we have successfully mitigated the outage by switching to our backup CDN provider.
Posted Nov 18, 2025 - 12:20 UTC
Resolved
This incident has been resolved.
Posted Nov 18, 2025 - 12:17 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Nov 18, 2025 - 12:14 UTC
Investigating
We are currently investigating a major outage across RTC due to a 3rd party provider, we will update this incident as are provided with more information from the 3rd party.
Posted Nov 18, 2025 - 11:56 UTC
This incident affected: RetroTechCollection Wiki (Website Frontend, Website Backend (MediaWiki), API), RetroTechCollection CDN, and RetroTechCollection Forum (Website Frontend, Website Backend (XenForo)).